Eador. Genesis — troubleshooting

Discussion in 'Eador. Genesis' started by Dan Spivakov, Dec 5, 2012.

  1. Dan Spivakov Administrator

    Please post here any troubles you have with running Eador. Genesis.

    So far the most problems had to do with 64-bit versions of Windows 7. Here is a possible solution to problems occurring on that configuration (taken from Eador.com's forum):

    1. Find (via Google) and install DXWnd (OG edition) tool
    2. Extract and run it, go to Edit -> Add.
    3. Press "..." button, find Eador.exe file
    4. Check up "Hook DirectDraw" option
    5. In Resolution tab choose your screen resolution (or set game default 1024x768).
    6. Check up "Auto-Correct Mouse Position" and "Don't Hide Mouse Pointer"
    7. Press ОК, go to Edit tab again and press Execute

    UPDATE:

    Another possible fix (taken from GOG.com):

    1. In Windows, create a new power plan (Control Panel > Hardware and Sound > Power Options). On the left, there should be a "Create a power plan" link.
    2. Choose Balanced, then give your plan a name (I called my "Throttle CPU"), then click Next.
    3. Choose the "turn of display" and "put the computer to sleep" options that you prefer, then click "Create."
    4. Next to your newly created plan, click the "Change plan settings" link. This brings you back to the display and sleep settings. Click the "Change advanced power settings" link that will now be visible below them.
    5. A Power Options window will pop up. Find the "Processor power management" setting, then expand it by clicking the + symbol. You'll then see some other things appear, one of which is "Maximum processor state."
    6. Expand the "Maximum processor state" setting. You'll see "Setting: 100%" next to it. Click that, and change it to something far lower (I set mine to 50%). I also went ahead and changed the"Minimum processor state" to 5%.
    7. Click OK.

    Now, when you choose your new plan, your CPU will not exceed 50% of it's maximum speed. Slowing my CPU down like this makes the game run smoothly, with no sound issues or mouse lag.

    Obviously you'll need to select a different power plan when you're finished playing Eador, otherwise your CPU will remain slow.

    ---

    If you're experiencing troubles due to the integrated Intel graphic card you may try this:

    Manually delete old video drivers, download and install latest version for your graphic card.

    ---

    How to fix lag:

  2. dojadoug New Member

    Can you please give a link to a DXWnd (OG Edition) download. I can't find one with google.
  3. sovereign New Member

    dojadoug:
    http://www.old-games.ru/utils/files/dxwnd_og.rar
    Download it, add Eador's executable file, and check three options-Hook DirectDraw, Auto-Correct Mouse Position and Don't Hide Mouse Pointer. After checking Hook DirectDraw, there will be possibility to choose Resolution. But if your unlucky like me, even this version of dxwnd wont work...

    After a few tries with different tools to force windowed mode I found out one that finally got windowed mode working for me on my latptop --> D3DWindower (got the english version)
    It required some trial and error to get it to work without bugs pestering the experience but it worked. So if dxwnd does nothing for you, try it.

    EDIT:
    These are my settings if anyone would like to save himself some trial-n-error:
    "Common" tab:
    Use windowed mode: check
    Use background resize: check
    Height: set if you want different than 1024
    Width: set if you want different than 768
    DLL: Browse to where you have D3DWindower and select the "D3dHook.dll"

    Direct Input:
    Use direct input: check

    Happy gamming !
  4. Sandermatt New Member

    dxwnd results in the same problems and doesnt fix it. The power managment doesn't help. And in the d3dwindower the eador doeasn't start (it asks for it administrator rights but then nothing happens.
  5. Sandermatt New Member


    Ok, I got it to work, I had to give the d3dwindower administrator rights.

Share This Page